Platform Downtime

Incident Report for StoryStream

Resolved

This incident has now been resolved.
Posted Aug 13, 2026 - 14:07 BST

Monitoring

The platform is back online. Some users may experience brief slowness while things fully stabilise β€” we're continuing to monitor closely and will update this page if anything changes. Thanks for your patience.
Posted Aug 13, 2026 - 11:31 BST

Investigating

We are currently investigating the issue.
Posted Aug 13, 2026 - 11:08 BST
This incident affected: Content Area πŸ“‚, Feeds πŸ’¬, Rights Management πŸ”’, Help Centre πŸ’‘, and AURA Workflows πŸ€–.